четверг, 11 декабря 2008 г.

Обмен данными КД.

До недавнего времени при обмене данными, между 7.7 и 8 использовал промежуточные файлы. Выгружал из источника или приемника нужные данные ОС и остатки по взаиморасчетам и загружал их в базу приемника (документом ввод остатков). Использовал для этого конечно же загрузку данных Ei

Однако время и объем задач внесли корректировки.
Вводная имеем 14 БУ 4.5 их нужно объединить в одну БД УПП 1.2.19.

Естественно, в данной ситуация свой взор я направил на КД и типовые обмены .
На диске ИТС есть все доступные правила, используя которые, можно перенести остатки практически из любой типовой Конфигурации.
  1. "Бухгалтерский учет", редакция 4.5 - файл Acc77.zip
  2. "Комплексная конфигурация", редакция 4.5 - файл Atc45.zip
  3. "Производство+Услуги+Бухгалтерия", редакция 2.8 - файл Mnfc28.zip
  4. "Торговля + Склад", редакция 9.2 - файл Tr92.zip
  5. "Управление торговлей", редакция 10.2 - файл UT10_2.zip
  6. "Управление производственным предприятием", редакция 1.2 - файл CnvUPP12.zip
  7. "Бухгалтерия предприятия", редакция 1.6 - файл BP1_6.zip
Взять эти правила можно здесь.
Одно но, все они для версии УПП 1.2.6 и платформы 8.0 .(очень оперативно :))

Нам предстоит нелегкий путь что бы преобразовать их для версии 1.2.19 (уже конечно 8.1).

Для того что бы избежать лишнюю трату времени, и для желающих самостоятельно выполнить преобразование пишу по пунктам.
  1. Загружаем правило в КД.
  2. Загружаем метаданные наших конфигураций. (в результате загрузки некоторые МД используемые в правилах будут помечены на удаление )
  3. Помеченные на удаление ПКО и ПКС
  4. В обработчиках исправляем следующие конструкции:
  • ЗначениеНеЗаполнено();
  • ПолучитьСведенияОСчете(),ПреобразоватьСчетаБУвСчетНУ() для них добавляем префикс общего модуля БухгалтерскийУчет.;
  • глТекущийПользователь;
  • Некоторые предопределенные значение поменяли Коды вместо 0009 например теперь 0000009 (Виды контактной информации).
  • Дополнительно к справочнику ФизЛица теперь у нас есть сотрудники организации.
  • Обработчик конвертации "После загрузки объекта" приводим к следующему виду //Не используем свойство автоматически сгенирировать номер или код
    //Так как используется параметр не выгружать коды справочников и номера документов
    Если Объект<>Неопределено Тогда
    Попытка
    Ссылка=Объект.Ссылка;
    Если (Справочники.ТипВсеСсылки().СодержитТип(ТипЗнч(Ссылка))
    ИЛИ ПланыВидовХарактеристик.ТипВсеСсылки().СодержитТип(ТипЗнч(Ссылка)))Тогда
    Если Не ЗначениеЗаполнено(Объект.Код) Тогда
    Объект.УстановитьНовыйКод();
    КонецЕсли;

    ИначеЕсли Справочники.ТипВсеСсылки().СодержитТип(ТипЗнч(Ссылка)) Тогда
    Если ТипЗнч(Ссылка)<> Тип("ДокументСсылка.ДокументРасчетовСКонтрагентом")
    и ТипЗнч(Ссылка)<> Тип("ДокументСсылка.ОтражениеПоступленияТоваровИУслугНДС")
    и ТипЗнч(Ссылка)<> Тип("ДокументСсылка.ОтражениеРеализацииТоваровИУслугНДС") Тогда

    Объект.Ответственный = ПараметрыСеанса.ТекущийПользователь;
    КонецЕсли;

    Если Не ЗначениеЗаполнено(Объект.Номер) Тогда
    Объект.УстановитьНовыйНомер();
    КонецЕсли;
    КонецЕсли;
    Исключение
    КонецПопытки;
    КонецЕсли;
После этого можно выгружать правила предварительно проверив ИХ. Перед проверкой учтите что многие ТЧ документов поменяли имена. Имена некоторых реквизитов изменены. Поэтому перед непосредственным удалением ПКС .. пройдите по свойствам. Легче изменить назначение чем их создавать заново, когда обнаружется, что что -то кудато не грузится.


Обращаем внимание на ПКО по учетной политике ( УчетнаяПолитикаОбщаяДля РегламентированногоУчета. и .т.д.) Данные ПКО используется в обработчике конфигурации "Перед выгрузкой данных" благополучно комментируем их, после удаления. //ВыгрузитьПоПравилу(,,,, "УчетнаяПолитикаОбщаяДляРегламентированногоУчета"); и тд.
Что бы не заморачивать с 5 значения, комментируем всю учетную политику по БУ и НУ внесем ее руками.

Это далеко не все сюрпризы которые Вас ожидают :). Помочь разобраться с другими ситуациями Вам безусловно поможет обработка отладки обработчиков :) (прикольно звучит) Режим отладки через Внешние обработки в совокупности с книгой по КД превратят для вас любую проблему в интересную задачку.

Если вы все таки дочитали до конца и вам не очень хочется возится с этими правилами самому, то вариант правил обмена оптимизированный на загрузку нескольких организация (помещение совместно используемых справочников в группы(склады, номенклатура)) для версий БУ 4.5.502-> УПП 1.2.19 можно преобрести всего за 1400 р. (в 3 раза меньше ставки 1 часа специалиста 1Cv8)