пятница, 2 октября 2009 г.

Отложенное проведение документов

Механизм отложенного проведения появился в конфигурации 1С: УПП начиная с релиза 1.2.20.
Задачи:

  • Повышение быстродействия и гибкости отражения в учете деятельности предприятия;
  • Увеличение параллельности работы пользователей.   




Механизм  опциональный, и начинает действовать для организации с определенной даты, для всех документов, которые являются регистратором для регистра сведений  "Документы требующие допроведения", а именно:
  1. АвансовыйОтчет
  2. ВозвратПереданныхТоваров
  3. ВозвратТоваровОтПокупателя
  4. ВозвратТоваровПоставщику
  5. ВозвратТоваровПоставщикуИзНТТ
  6. ГТДИмпорт
  7. КомплектацияНоменклатуры
  8. ОприходованиеМатериаловИзПроизводства
  9. ОприходованиеТоваров
  10. ОтчетКомиссионераОПродажах
  11. ОтчетОРозничныхПродажах
  12. ОтчетПроизводстваЗаСмену
  13. ПередачаТоваров
  14. ПеремещениеТоваров
  15. ПолучениеУслугПоПереработке
  16. ПоступлениеДопРасходов
  17. ПоступлениеТоваровИзПереработки
  18. ПоступлениеТоваровУслуг
  19. ПоступлениеТоваровУслугВНТТ
  20. РеализацияОтгруженныхТоваров
  21. РеализацияТоваровУслуг
  22. РеализацияУслугПоПереработке
  23. СписаниеТоваров
  24. ТребованиеНакладная
  25. ВыпускПродукции
  26. УслугиСобственнымПодразделениям
Ограничить список этих документов стандартными средствами не получится, придется изменять процедуру общего модуля ОтложенноеПроведениеДокументов

// Функция возвращает признак того, что документ используется в отложенном проведении
//
Функция ДокументПодерживаетОтложенноеПроведение(ДокументОбъект, СтруктураШапкиДокумента = Неопределено) Экспорт
    //Используется ли вообще отложенное проведение по дате и организации, указанным в документе
    Если НЕ ИспользуетсяОтложенноеПроведение(СтруктураШапкиДокумента,ДокументОбъект) Тогда
        Возврат Ложь;
    КонецЕсли;
    //ограничиваем определенные документы
    Если ТипЗнч(ДокументОбъект)=Тип("ДокументОбъект.РеализацияТоваровУслуг") Тогда
        Возврат Ложь;
    КонецЕсли;

    Возврат ДокументОбъект.Метаданные().Движения.Содержит(
            РегистрыСведений.ДокументыТребующиеДопроведения.СоздатьНаборЗаписей().Метаданные());

КонецФункции // ДокументПодерживаетОтложенноеПроведение

Формирование движений документа по регистрам производится в два этапа:
  • Проведение: формируются движения по части регистров требующих оперативного отражения Например для реализации это: (Заказы покупателей, Продажи, Взаиморасчеты, Товары на складах, Товары организации);
  • Допроведение: формируются движения по остальным регистрам;
очень удобным в этом плане является журнал документов "Отложенное проведение документов" В журнал попадают все документы (регистраторы РС "ДокументыТребующиеДопроведения") по организациям для которых используется отложенное проведение.
Проведенные документы показываются разными пиктограммами в зависимости от того, проведены они полностью (стандартная пиктограмма) либо требуют допроведения (пиктограмма желтого цвета).

Есть возможность:

  • провести документ полностью по всем регистрам (меню «Действия» пунт «Провести полностью», либо с помощью контекстного меню);
  • сформировать диаграмму отложенного проведения (кнопка «Отчеты»).

Формировать окончательные движения для документа пользователь(система) может 3 способами:
  1. Из журнала "Отложенное проведение документов";
  2. Обработкой "Допроведение документов"
  3. Используя регламентные задания , если в настройке Допроведения документов установлено расписание. 
В последнем случае пользователь не получит информационных сообщений (например о том что не списаны партии) в отличие от использования обработки "Допроведение документов".

В этой обработке необходимо выбрать настройку отложенного проведения, для заполнения первоначальными значениями документов и периода.  В случае выбора "только требующие допроведения" будут отобраны документы из регистра сведений "Документы требующие допроведения" попадающие в указанный период. Если выбрать "все" тогда будут отобраны следующие документы:
- Для данного вида документа предусмотрено отложенное проведение (является регистратором регистра сведений "ДокументыТребующиеДопроведения" Функция ДокументПодерживаетОтложенноеПроведение в данном случае игнорируется)
- Проведен,
- Отражается в БУ
- Организация - соответствующая параметрам
- Дата документа попадает в период допроведения

ВЫВОДЫ.

В целом "механизм" довольно работоспособный, однако на мой взгляд есть ряд недостатков:
  • не хватает гибкости 



    • Отбирать определенные типы документов;
    • Включать отложенное проведение для конкретного пользователя;



  • отсутствует система логирования ошибок при использовании автоматического режима;
  • ну и собственно достаточно сложно переломить систему мышления пользователя, который привык сделать документ и сразу увидеть результат своего труда.